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ABSTRACT: The article aims to develop a visual application with databases in visual studio .net.
The paper shows the following important aspects such as: creating a simple interface in visual
studio, how to connect a database to the interface, how to define the database in visual studio, how
the bindingnavigator can be used, performing some basic operations on the created database.
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1. INTRODUCTION

In the Visual Studio .NET development
system you can create visually (by selecting
from toolbars) both the communication
objects with the database (connections,
commands, adapter, data set), as well as the
graphical controls for displaying the data:
display lists (ListView), display boards
(DataGrid) and connections between them
[1].

Visual Studio and .NET together provide
extensive APl and tooling support for
connecting to databases, modeling data in
memory, and displaying the data in the user
interface. The .NET classes that provide data-
access functionality are known as ADO.NET.
ADO.NET, along with the data tooling in
Visual Studio, was designed primarily to
support relational databases and XML. These
days, many NoSQL database vendors, or third
parties, offer ADO.NET providers [2].

.NET Core supports ADO.NET, except for
datasets and their related types. If you're
targeting .NET Core and require an object-
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relational mapping (ORM) layer, use Entity
Framework Core.

The following diagram shows a simplified
view of the basic architecture [3]:
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Fig. 1. The diagram of the .net core
architecture [3]
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2. CREATE APROJECT AND A
LOCAL DATABASE

In order to attach a blank database to a visual
studio project, we must go through the
following steps:
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1.

2.

3.

4.

Create a new Windows Forms App
project and name it.

On the menu bar, select Project > Add
New ltem.

In the list of item templates, scroll
down and select Service-based
Database.

Name it the database, and then click
Add.

Figure 2 shows the primary interface to form
Form1 file created in Visual Studio Windows

Forms.

Fig
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. 2. Creating the project interface in

windows forms

A. Add a data source to our project:

1.

If the Data Sources window isn't open,
open it by pressing Shift+Alt+D or
selecting View > Other Windows >
Data Sources on the menu bar.

In the Data Sources window, select
Add New Data Source. The Data
Source Configuration Wizard opens.
On the Choose a Data Source Type
page, choose Database and then
choose Next.

On the Choose a Database Model
page, choose Next to accept the
default (Dataset).

On the Choose Your Data Connection
page, select the Contacte.mdf file in
the drop-down list, and then choose
Next.
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6.

On the Save the Connection String to
the Application Configuration File
page, choose Next.

On the Choose your Database Objects
page, you'll see a message that says
the database doesn't contain any
objects. Choose Finish.

We can view the connection string for the
Contacte.mdf file by opening the Properties

window of the data connection:

Select View > SQL Server Object
Explorer to open the SQL Server
Object Explorer window. Expand
(localdb)\MSSQLLocalDB >
Databases, and then right-click on
Contacte.mdf and select Properties.
Alternatively, we can select View >
Server Explorer, if that window isn't
already open. Open the Properties
window by expanding the Data
Connections node, right-clicking on
Contacte.mdf, and then selecting
Properties.

B. Create tables and keys by using Table
Designer

In this section, we'll create a table with ten
columns, a primary key in table, and a few
rows of sample data.

Create the Contacte table

1.

In Server Explorer, expand the Data
Connections node, and then expand
the Contacte.mdf node. If you can't
expand the Data Connections node, or
the Contacte.mdf connection is not
listed, select the Connect to Database
button in the Server Explorer toolbar.
In the Add Connection dialog box,
make sure that Microsoft SQL Server
Database File is selected under Data
source, and then browse to and select
theSampleDatabase.mdf file. Finish
adding the connection by selecting
OK.
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Right-click on Tables and select Add 7. In the upper-left corner of Table
New Table. The Table Designer opens Designer, select Update.

and shows a grid with one default row, 8. In the Preview Database Updates
which represents a single column in dialog box, select Update Database.
the table that you're creating. By The Contacte table is created in the
adding rows to the grid, you'll add local database file.

columns in the table. Figure 3 shows the table construction to
3. In the grid, add a row for each of the configure the database. For each field, the
entries. type of data contained is selected and can be
4. Right-click on the ContactID row, and checked if it allows nullity (except making the
then select Set Primary Key. primary key which cannot be null). Figure 4
5. Right-click on the default row (ld), shows the database, containing 10 lines and
and then select Delete. 10 columns.

6. Name the Contacte table by updating
the first line in the script pane to
match the following sample.

b@ File Edit View Project Build Debug Test Analyze Tools  Extensions Window Help  Search [ q 2 od Signin A, 5] x
- PRl " Y ] - & - | Debug ~ AnyCPU - b ostate| g0 o = |& LiveShare &

dboContacte [Design] + X [aeaelty(sr]
4 Update | saiptFile  dboContactesgl

210/dx3 J3AIAG

Name DataType  Allow Nulls Default 4 Keys (1)
o Contactld int <unnamed> (Primary Key, Clustered: Contactid)
Check Constraints (0)

Indexes ()

Foreign Keys (0)

Triggers (0)

Nume nvarchar(50)
Prenume nvarchar(s0)
facultatea nvarchar(50)
4 @ ContactDB.mdf
T ContactDB_log.df
4 B fomics
b 1) Formi.Designercs
) Form1resk
b o Program.cs

Specializarea  nvard har(0)
Grupa int
An de studiu int

telefon int

1210/0x3 193/a0) JAIIS TOS  XOQIO0L

email nvarchar(50)

[N U A U AR AN

Forma de invatamant  nvarc! har(50)

g
g
3

B orsa
=CREATE TABLE [dbo].[Contacta]
[ContactTd] ™t
[Nume] HVARCHAR BS
[Pr NVARCHAR £E EEL A
NVARCHAR =
NVARCHAR

Contacte Table

NVARCHAR

2 )| The name of the schema object

Fig. 3. Define the table for the database

m File Edit View Project Build Debug SQL Test Analyze Tools Extensions Window Help Search (Ctrl+Q) P ex3

S0~ Bre o - ~| Debug ~ AnyCPU ~ B Start+| 5 o

§ dbo.Contacte [Data] ® X EEelinjis3 Program.cs Form1.Designer.cs Form1.cs [Design]

g ¢ Yo Y %  MaxRows 1000 - oo

% Contactld | Nume Prenume | Facultatea | Specializarea Grupa An de studiu | telefon email Forma de invatamant
s P_ 1 Popescu lonut Inginerie Automatica 114 1 742342118 pop.ionut@gmail.com zi

g |2 lonescu Emil Inginerie Automatica 114 1 756345224 ionescu.emil@yahoo.com  zi

g 3 Popa Alin Inginerie Automatica 114 1 763243899 popa.alin@yahoo.com zZi

= b4 Paun Marius Inginerie Tehnologia Constructiilor de masini = 111 1 735222676 pauni2@gmail.com zi

5 L H Banulescu Claudiu Inginerie Managementul Energiei 112 1 724356278 claudiu17@gmail.com zi

& |6 Sanda Maria Inginerie Mediu si alimentatie publica 123 2 766556778 mariasanda@gmail.com id

é 7 Cotojman lonut Inginerie Inginerie medicala 133 3 769453245 ionut.cotojman@gmail.com id

E 8 Cotojman Danut Inginerie Inginerie medicala 144 4 755465378 danut56@gmail.com id

a L |9 Samoila Mirela Inginerie Managementul Enenrgiei 144 4 742342665 mirelag7 @gmail.com id

g 10 Surugiu loana Inginerie Automatica 124 2 767578673 ioana.surugiu@gmail.com  zi

g X NULL NULL NULL NULL NULL NULL NULL NULL NULL NULL

Fig. 4. The display the database created in visual studio
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3. BINDINGNAVIGATOR
CONTROL OVERVIEW
(WINDOWS FORMS)

We can use the BindingNavigator control to
create a standardized means for users to
search and change data on a Windows Form.
You frequently use BindingNavigator with
the BindingSource component to enable users
to move through data records on a form and
interact with the records.

@y Formi

1 of10 | b Pf

XN

The BindingNavigator control is composed of
a ToolStrip with a series of ToolStripltem
objects for most of the common data-related
actions: adding data, deleting data, and
navigating through data [4]. By default, the
BindingNavigator control contains these
standard buttons. The following screenshot
shows the BindingNavigator control on a
form created.

Contactld

lonescu Emil
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Inginerie
Inginerie
Popa Alin Inginerie
Paun Marius Inginerie

Banulescu Claudiu Inginerie

Sanda Mana Inginerie

Cotojman lonut Inginerie

o u o o ewn

Cotojman Danut Inginerie

9 Samoila Mirela Inginerie

10 Surugiu loana Inginerie

Facultatea

Specializarea An de studiu telefon

Automatica T4234211E

Automatica 756345224
Automatica 76324389¢
Tehnologia Constructi... 73522267¢
Managementul Energiei 72435627¢
Mediu si alimentatie pu... T6655677¢
Inginerie medicala 133 76945324
Inginerie medicala 144 75546537¢

Managementul Enenrgiei | 144 742342665

N B e R N =a=]==

Automatica 124 76757867
v

>

Fig. 5. The display the database using binding browser

4. THE BASIC OPERATIONS ON
THE CREATED DATABASE

In the created database we can execute basic
commands that are applied to most databases:
selection, insertion, deletion.

A. Selection from the database
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The selection operation is performed to
select only certain data from the database.
Figure 6 presents the requirement for
selection from the database of students
who are in the specialization Automatic
and group 114.
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Dq File Edit View Project Build Debug Test Analyze Toocls Extensions W

< Bro me - ~ | Debug ~ AnyCPU v P Statv| pv -

SQlOQuerylsgl* + X KleleXEshiclacRINEIE]) SQLQuery1.sgl * Form1l.cs
b - v 5 wf mf C\USERS\GHEOR\SOURCE\REPOS ~ %3 | &2 - 59  E1

-1Select Nume,Prenume, Specializarea,Grupa from Contacte

Where Specializarea ='Automatica'
And Grupa ='114";

100% ~ @ No issues found
& T-5aL t4

MNume Prenume Specializarea Grupa

B Message

lonut Automatica 114
2 lonescu Emil Automatica 114
Popa Alin Automatica 114

a Jesojdxg 1elgo senes TS J2u0]dx] JBmnes

Fig. 6. The interrogation of the database for the selection and display of the result

B. The insertion into a database inserted row, this being the row with the
number 11.
This operation is important because we
almost always have to enter data after the
database has been created. Figure 7 shows the
database that was completed with the newly

s Form1 — O X
1 oft1 | b bl X W
Contactld Nume Prenume Facultatea Specializarea Grupa An de studiu telefon
3 Popa Alin Inginerie Automatica 114 1 76324385¢
4 Paun Marius Inginerie Tehnologia Constructiil... | 111 1 73522267¢
5 Banulescu Claudiu Inginerie Managementul Energiei | 112 1 72435627¢
6 Sanda Maria Inginerie Mediu si alimentatie pu... | 123 2 7T6655677E
7 Cotojman lonut Inginerie Inginerie medicala 133 3 76945324F
8 Cotojman Danut Inginerie Inginerie medicala 144 4 75546537¢
9 Samoila Mirela Inginerie Managementul Enenrgiei | 144 4 742342665
10 Surugiu loana Inginerie Automatica 124 2 767578677
1 Balan lon Inginerie Automatica 123 2 754345261
* W
< >

Fig. 7. The insertion of a new row in the database

C. Deleting from the database

The deleting operation is performed to
remove data from the database.

Figure 8 shows the result of erasing the
student with id 5.

44



Annals of the ,,Constantin Brancusi” University of Targu Jiu, Engineering Series , No. 4/2019

SQLQuerylsgl* +# X Elinhie3 Program.cs Form1.Designer.cs
b= v B mi mf C\USERS\GHEOR\SOURCE\REPOS + %3 | 28 -~ 2 B
Fldelete from contacte
where ContactId='5";
s Form1 - [} X
1 of10| b bl X
Contactld Nume Prenume Facultatea Specializarea Grupa An de studiu telefon
» Popescu lonut Inginerie Automatica 14 1 T4234211€
1?!0 2 lonescu Emil Inginerie Automatica 114 1 756345224
3 Popa Alin Inginerie Automatica 114 1 76324385¢
4 Paun Marius Inginerie Tehnologia Constructiil... | 111 1 73522267¢
6 Sanda Maria Inginerie Mediu si alimentatie pu... | 123 2 766556778
7 Cotojman lonut Inginerie Inginerie medicala 133 3 76945324F
8 Cotojman Danut Inginene Inginerie medicala 144 4 755465378
o8 9 Samoila Mirela Inginerie Managementul Enenrgiei | 144 4 742342665
@ 10 Surugiu loana Inginerie Automatica 124 2 767578672
o 1 Balan lon Inginerie Automatica 123 2 754345261 .
Sed & kd

Fig. 8. The deleting of row with id 5 from the database

5. CONCLUSIONS

The Visual Studio .net development
environment has powerful and suggestive
tools for using databases in applications.
Every institution or private company
currently uses at least one database with
information, and the simple way of
creating and interrogating the database in

visual studio would improve the
widespread use of these types of
applications. Conceptually, behind a

window where we work with data retrieved
from one or more tables of a database are
the objects in the categories Connection,
Command, DataAdapter and DataSet.
What can be seen there are controls of the
type DataGridView, or TableGridView,
BindingNavigator, etc.
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